Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Steering wheel controls not lit?

  1. #1
    Junior Member
    Join Date
    Dec 2017
    Location
    Cornwall, ON
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Steering wheel controls not lit?

    My wife's 2015 SV's steering wheel controls on LEFT side are not lit (only) right...is this normal? If not, is it just a simple fuse change? If so, which one please? Well, just called her (on Bluetooth)...now she's saying they're lit, but not as much as right side?? Is there a brightness control, or can I be dealing with faulty wiring here? Anybody run into this before? Thank you.



  2. #2
    Junior Member
    Join Date
    Sep 2016
    Location
    Marystown nl
    Posts
    6
    Garage empty: add car
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Had to replace clock spring on mine. 2016 sv

        __________________________________________

        click to view fuel log View my fuel log 2016 Micra Sv automatic: 6.8 L/100 km ... 41.4 mpg (Imp) ... 14.7 km/L ... 34.5 mpg (US) ...


  3. #3
    Senior Member MrMicra2015's Avatar
    Join Date
    Aug 2016
    Location
    Vancouver BC
    Posts
    306
    Thanks
    57
    Thanked 43 Times in 31 Posts
    this isnt helpful...but you should have got an S...not even a passenger vanity mirror!!
    2015 Micra S (manual)
    no A/C /no power options
    Feb 2015 build
    9,999 purchase price + tax..no additional 1600$ because it was a 2015 purchased in 2016
    so receipt says $8,399....+1600 .... so they look good i guess...for a brand new car!

  4. #4
    Junior Member
    Join Date
    Nov 2018
    Location
    Kitchener
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts
    This is not normal. both sides should be lit equally and there is no dimmer for steering wheel illumination. I don't know how to fix it, but I just know as an SV owner, its not normal. Its also not likely a fuse. A fuse either works or it doesn't. My guess would be a bad connection or a wire thats shorting out somewhere.

  5. #5
    Junior Member
    Join Date
    Sep 2016
    Location
    Marystown nl
    Posts
    6
    Garage empty: add car
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Richard View Post
    This is not normal. both sides should be lit equally and there is no dimmer for steering wheel illumination. I don't know how to fix it, but I just know as an SV owner, its not normal. Its also not likely a fuse. A fuse either works or it doesn't. My guess would be a bad connection or a wire thats shorting out somewhere.
    Had the same problem with the steering wheel lighs, caused by a bad clock spring

        __________________________________________

        click to view fuel log View my fuel log 2016 Micra Sv automatic: 6.8 L/100 km ... 41.4 mpg (Imp) ... 14.7 km/L ... 34.5 mpg (US) ...


  6. #6
    Junior Member
    Join Date
    Dec 2017
    Location
    Cornwall, ON
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Ok, thanks. Just looked up some videos on it...not exactly the simplest thing to do. Will think about it...just a nuisance really.

  7. #7
    Senior Member
    Join Date
    Jun 2017
    Location
    Durham Region, Ontario
    Posts
    133
    Thanks
    8
    Thanked 22 Times in 19 Posts
    My 2015 SV also went, twice. They replaced the clock spring twice (although the first time I dont believe it was actually done due to a very well known shoddy nissan dealer) even though there was no reason for it to go twice in 4 weeks. (again why I believe the first time it was never done, only tinkered with)

    *under warranty until May 2019
    Micra Meets: Mosport '18

    Car Girls FTW.

    Interior mods only right now.

  8. #8
    Junior Member
    Join Date
    Dec 2017
    Location
    Cornwall, ON
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Wayward_0ne View Post
    My 2015 SV also went, twice. They replaced the clock spring twice (although the first time I dont believe it was actually done due to a very well known shoddy nissan dealer) even though there was no reason for it to go twice in 4 weeks. (again why I believe the first time it was never done, only tinkered with)

    *under warranty until May 2019
    Hmm...interesting. Seems to be pretty common...

  9. #9
    Member
    Join Date
    Sep 2016
    Posts
    40
    Thanks
    0
    Thanked 1 Time in 1 Post
    Quote Originally Posted by markarita View Post
    Ok, thanks. Just looked up some videos on it...not exactly the simplest thing to do. Will think about it...just a nuisance really.
    You could just go to the dealership, this must still be under warranty if it's a 2016, no?

  10. #10
    Junior Member
    Join Date
    Dec 2017
    Location
    Cornwall, ON
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts
    It's a 2015...bought it used in 2017. I guess I can go see...wouldn't hurt to try. Thx.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •