Results 1 to 8 of 8

Thread: Power steering failiure

  1. #1
    Junior Member
    Join Date
    Nov 2019
    Location
    Montreal
    Posts
    1
    Garage empty: add car
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Power steering failiure

    2015 micra. Ps lingt's on . No steering wheel , no code found , any tip need help thx



  2. #2
    Administrator MetroMPG's Avatar
    Join Date
    Feb 2014
    Location
    1000 Islands, Ontario
    Posts
    4,579
    Thanks
    1,548
    Thanked 574 Times in 441 Posts
    Sounds like either a connector/wiring issue or the motor itself.

    The power steering components are all inside the car, under the dashboard. The electric motor assists the steering shaft, rather than the steering rack under the hood like hydraulic systems.

    I did a search here and I haven't seen any other Micra owners mentioning this problem.

    Are you out of warranty?

    Might be worth searching the U.S. Nissan Versa forum - same components as our Micra.

        __________________________________________

        click to view fuel log View my fuel log 2015 Micra S manual: 5.0 L/100 km ... 56.5 mpg (Imp) ... 20.0 km/L ... 47.0 mpg (US) ...


  3. #3
    Senior Member MrMicra2015's Avatar
    Join Date
    Aug 2016
    Location
    Vancouver BC
    Posts
    603
    Thanks
    131
    Thanked 85 Times in 71 Posts
    https://www.nicoclub.com/FSM/Versa/2016%20Versa%20Note/

    i assume you mean....no power steering,,steering very hard..cause if the steering wheel is missing that may throw a code
    2015 Micra S (manual)
    no A/C /no power options
    Feb 2015 build
    9,999 purchase price + tax..no additional 1600$ because it was a 2015 purchased in 2016
    so receipt says $8,399....+1600 .... so they look good i guess...for a brand new car!

    Covid 19...she up on blocks!!!

  4. #4
    Administrator MetroMPG's Avatar
    Join Date
    Feb 2014
    Location
    1000 Islands, Ontario
    Posts
    4,579
    Thanks
    1,548
    Thanked 574 Times in 441 Posts
    Any update, 2zy2?

        __________________________________________

        click to view fuel log View my fuel log 2015 Micra S manual: 5.0 L/100 km ... 56.5 mpg (Imp) ... 20.0 km/L ... 47.0 mpg (US) ...


  5. #5
    Junior Member
    Join Date
    Aug 2018
    Location
    Latin America
    Posts
    2
    Thanks
    0
    Thanked 2 Times in 1 Post
    I had some issue with power steering: PS on.
    I found battery terminals loosen.
    Cleaned and adjusted and everything fixed.

  6. The Following 2 Users Say Thank You to S_dorian For This Useful Post:

    MetroMPG (12-23-2019),MrMicra2015 (10-27-2020)

  7. #6
    Junior Member
    Join Date
    Oct 2020
    Location
    Sharbot Lake Ontario
    Posts
    1
    Garage empty: add car
    Thanks
    0
    Thanked 0 Times in 0 Posts
    My friend has a 2017 micra base model . He has been having many issues since buying it New . He needs help with the P S light coming on . At the same time he says the car is hard to start but he does get it started after a few turns of the key . I would appreciate any help , people on this forum can give me . Oh one final note would any of this be covered under warranty ? Thank you to everyone .

  8. #7
    Senior Member MrMicra2015's Avatar
    Join Date
    Aug 2016
    Location
    Vancouver BC
    Posts
    603
    Thanks
    131
    Thanked 85 Times in 71 Posts
    looks like the easy fix is tighten battery terminal?
    2015 Micra S (manual)
    no A/C /no power options
    Feb 2015 build
    9,999 purchase price + tax..no additional 1600$ because it was a 2015 purchased in 2016
    so receipt says $8,399....+1600 .... so they look good i guess...for a brand new car!

    Covid 19...she up on blocks!!!

  9. #8
    Member
    Join Date
    Jul 2015
    Posts
    42
    Garage empty: add car
    Thanks
    7
    Thanked 6 Times in 4 Posts
    Quote Originally Posted by 2zy2 View Post
    2015 micra. Ps lingt's on . No steering wheel , no code found , any tip need help thx
    Had this issue with my 07 sentra when it’s was about 5 years old as well. Turns out it was the battery similar to another poster above. My terminals were fine but the battery was on its way out.

    NUBS



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •