Page 3 of 12 FirstFirst 123456789101112 LastLast
Results 21 to 30 of 114

Thread: Micra speedometer shows faster than it's really going

  1. #21
    Administrator MetroMPG's Avatar
    Join Date
    Feb 2014
    Location
    1000 Islands, Ontario
    Posts
    3,541
    Thanks
    1,036
    Thanked 457 Times in 346 Posts

    speed in car's OBD-II computer vs. speedometer

    Confirmed in the SR automatic I'm driving that the speedometer is consistently reading 4 km/h higher than the car's computer, which looks to me like a correction factor. I used an OBD-II scan tool (ScanGauge-e) and checked from 30-100 km/h:

    Speedometer reports...
    OBD-II value...
    30 26
    40 36
    50 46
    60 56
    70 66
    80 76
    90 86
    100 96

    I didn't check against the odometer, but will do that too. I bet the dash display matches the OBD-II values.


        __________________________________________

        click to view fuel log View my fuel log 2015 Micra S manual: 5.0 L/100 km ... 56.5 mpg (Imp) ... 20.0 km/L ... 47.0 mpg (US) ...


  2. #22
    Administrator MetroMPG's Avatar
    Join Date
    Feb 2014
    Location
    1000 Islands, Ontario
    Posts
    3,541
    Thanks
    1,036
    Thanked 457 Times in 346 Posts

    odometer accuracy

    (Revised post...)

    I did a 20+ km drive over a measured distance (Google Earth), and the Micra's odometer matched the mapped distance exactly to the tenth of a KM.

    So the speedometer seems to be offset, but not the odometer.

    Earlier I had said that my OBD-II gauge didn't match the dashboard odometer, but I screwed that up. They DO match.

        __________________________________________

        click to view fuel log View my fuel log 2015 Micra S manual: 5.0 L/100 km ... 56.5 mpg (Imp) ... 20.0 km/L ... 47.0 mpg (US) ...


  3. #23
    Senior Member Howie's Avatar
    Join Date
    Jun 2014
    Location
    Trenton, Ontario, Canada
    Posts
    752
    Thanks
    86
    Thanked 224 Times in 146 Posts
    just finished running mine down the 401.. 2 GPS's and a BB gps all show that my micra is going 5kph then what it indicates..

        __________________________________________

        click to view fuel log View my fuel log 2015 Micra S automatic: 7.9 L/100 km ... 35.7 mpg (Imp) ... 12.6 km/L ... 29.7 mpg (US) ...


  4. #24
    Administrator MetroMPG's Avatar
    Join Date
    Feb 2014
    Location
    1000 Islands, Ontario
    Posts
    3,541
    Thanks
    1,036
    Thanked 457 Times in 346 Posts
    Did you check them against the odometer as well?

        __________________________________________

        click to view fuel log View my fuel log 2015 Micra S manual: 5.0 L/100 km ... 56.5 mpg (Imp) ... 20.0 km/L ... 47.0 mpg (US) ...


  5. #25
    Senior Member Howie's Avatar
    Join Date
    Jun 2014
    Location
    Trenton, Ontario, Canada
    Posts
    752
    Thanks
    86
    Thanked 224 Times in 146 Posts
    .... Didnt check it against the gps tripmeter. I should have. But I do suspect its off a little as well. I set a tripmeter, and its normally about 350km (1-2 km off).. The result I had was about 358.5 if memory serves.

    I didnt think too much into it, and im no math wiz but I think that would be around about for every 100,000 would be 2,400km out.. so If you drive 100,000km, your indicated milage would be 102,400.

    Im not ready to go raising the pitchforks and torches over 2,400km. But I would like the speedo calibrated so it indicates properly. Usually I stay 10kph over on highways and around 5kph rural, and at the speed limit or less in residential areas.

    So this means on the 401 where i should be slowly passing tractors on the right (105-107kph depending on thier setup) Im getting passed by them. Not a huge deal but it is annoying.
    Last edited by Howie; 07-16-2014 at 10:31 PM.

        __________________________________________

        click to view fuel log View my fuel log 2015 Micra S automatic: 7.9 L/100 km ... 35.7 mpg (Imp) ... 12.6 km/L ... 29.7 mpg (US) ...


  6. #26
    Administrator MetroMPG's Avatar
    Join Date
    Feb 2014
    Location
    1000 Islands, Ontario
    Posts
    3,541
    Thanks
    1,036
    Thanked 457 Times in 346 Posts
    I just updated my earlier post with corrected info:

    The Micra's odometer matched a mapped out distance perfectly (Google Earth), as well as the OBD-II gauge.

        __________________________________________

        click to view fuel log View my fuel log 2015 Micra S manual: 5.0 L/100 km ... 56.5 mpg (Imp) ... 20.0 km/L ... 47.0 mpg (US) ...


  7. #27
    Senior Member Howie's Avatar
    Join Date
    Jun 2014
    Location
    Trenton, Ontario, Canada
    Posts
    752
    Thanks
    86
    Thanked 224 Times in 146 Posts
    Ok, cool. Thats a lot more accurate then what eyeball. Heck.. I miss en exit on london and that can make 8-9km extra..

    Less worried about the odometer then I am about the speedo.

        __________________________________________

        click to view fuel log View my fuel log 2015 Micra S automatic: 7.9 L/100 km ... 35.7 mpg (Imp) ... 12.6 km/L ... 29.7 mpg (US) ...


  8. #28
    Senior Member aftica's Avatar
    Join Date
    May 2014
    Posts
    370
    Thanks
    0
    Thanked 67 Times in 47 Posts
    Passing one of those neighbourhood radar signs and i'm getting a 54KMH reading whilst my speedo reads 60KMH. I have always found that these jive pretty well with various vehicles I've driven, but that is not to say this one couldn't be even wonkier than the Micra speedo
    Ten Grand Tin Can

        __________________________________________

        click to view fuel log View my fuel log 2015 Micra S manual: 5.3 L/100 km ... 53.2 mpg (Imp) ... 18.8 km/L ... 44.3 mpg (US) ...


  9. #29
    Junior Member
    Join Date
    Oct 2014
    Location
    Toronto
    Posts
    12
    Thanks
    5
    Thanked 2 Times in 2 Posts
    So has anyone made any progress with the dealership or Nissan? I am off 8-10kph on the Speedo.

  10. #30
    Member
    Join Date
    Jun 2014
    Posts
    38
    Garage empty: add car
    Thanks
    0
    Thanked 6 Times in 4 Posts
    I went to the dealer last week and they confirmed it is off and they have no solution at this time ... They have forwarded info to Nissan canada ... Again my assumption is these cars were specially made with 15" tires for canada and probably somehow missed the programming of the ecu ... I will try changing tires size and testing.



  11. The Following User Says Thank You to hyedegha For This Useful Post:

    MicraMan (10-30-2014)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •