Results 1 to 8 of 8

Thread: CEL PO 181 fuel temp. sensor???

  1. #1
    Senior Member Pete's Avatar
    Join Date
    Sep 2014
    Location
    Peterborough
    Posts
    772
    Thanks
    546
    Thanked 277 Times in 194 Posts

    CEL PO 181 fuel temp. sensor???

    Has anyone had this yet? Not sure if mine was caused at the fuel pump or at the fuel rail. I cleared the code i will see if it comes back.



  2. #2
    Administrator MetroMPG's Avatar
    Join Date
    Feb 2014
    Location
    1000 Islands, Ontario
    Posts
    3,981
    Thanks
    1,232
    Thanked 505 Times in 388 Posts
    I've never even HEARD of a fuel temp sensor before.

        __________________________________________

        click to view fuel log View my fuel log 2015 Micra S manual: 5.0 L/100 km ... 56.5 mpg (Imp) ... 20.0 km/L ... 47.0 mpg (US) ...


  3. #3
    Senior Member Pete's Avatar
    Join Date
    Sep 2014
    Location
    Peterborough
    Posts
    772
    Thanks
    546
    Thanked 277 Times in 194 Posts
    I am starting to think it might be cooling fan related as it is a combination of signals from ambient air temp. coolant temp and fuel temp. so it could be possible that a high coolant temp on a cold night could set it off.... if say the fuse or relay for the cooling fan was gone for a turd.
    Either that or possibly a short in the wiring between the fuel pump and the ECM.

  4. #4
    Senior Member Pete's Avatar
    Join Date
    Sep 2014
    Location
    Peterborough
    Posts
    772
    Thanks
    546
    Thanked 277 Times in 194 Posts
    Has anyone had a check engine light for the cooling fan not working?
    I am convinced that my po181 fuel temp sensor cel was caused by this as since i cleared the code i have kept my engine temp in check by not leaving it idle at a stop and having my blower motor going full in traffic when the speed is not enough to flow air through the rad and have not seen this code return.
    You would think they would have a CEL for the cooling fan itself of at least a coolant temp warning code or light but i have not seen any just the fuel temp. sensor code.

  5. #5
    Have you tried swapping MAF sensors to see if it’s the IAT ? But if you keep getting the same code for that same thing try the test on the FTT ... tho, that does look like a shitting process I’m not gonna lie. Try the cheapest ones first ... lol right?

        __________________________________________

        click to view fuel log View my fuel log 2015 Micra S manual: 7.7 L/100 km ... 36.8 mpg (Imp) ... 13.0 km/L ... 30.6 mpg (US) ...


  6. #6
    Senior Member Pete's Avatar
    Join Date
    Sep 2014
    Location
    Peterborough
    Posts
    772
    Thanks
    546
    Thanked 277 Times in 194 Posts
    I am pretty sure i know what is up with this.
    As soon as I have a day when the weather is nice and I am not driving the car I will solve this once and for all.
    The po181 code has not come back since I cleared it.
    I have been monitoring coolant temp. and for one reason or another my rad fan is not working weather that be a relay , fuse or the fan itself is yet to be seen.

  7. #7
    Quote Originally Posted by Pete View Post
    I am pretty sure i know what is up with this.
    As soon as I have a day when the weather is nice and I am not driving the car I will solve this once and for all.
    The po181 code has not come back since I cleared it.
    I have been monitoring coolant temp. and for one reason or another my rad fan is not working weather that be a relay , fuse or the fan itself is yet to be seen.
    I got a spare rad fan. Itís not perfect is for spare parts it might be handy?

        __________________________________________

        click to view fuel log View my fuel log 2015 Micra S manual: 7.7 L/100 km ... 36.8 mpg (Imp) ... 13.0 km/L ... 30.6 mpg (US) ...


  8. #8
    Senior Member MrMicra2015's Avatar
    Join Date
    Aug 2016
    Location
    Vancouver BC
    Posts
    220
    Thanks
    37
    Thanked 30 Times in 19 Posts
    http://www.nisentra.com/p0181_ftt_sensor-544.html

    useful?


    2015 Micra S (manual)
    no A/C /no power options
    Feb 2015 build

  9. The Following 2 Users Say Thank You to MrMicra2015 For This Useful Post:

    MetroMPG (03-21-2018),Pete (03-20-2018)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •